Monday, 31 August 2020

Upgrading pi-hole on Ubuntu 18.04 problems

 If you've tried to upgrade pi-hole running on 18.04LTS then you might have gotten an error like this:

The following packages have unmet dependencies:
       lighttpd : Depends: libssl1.1 (>= 1.1.0) but it is not going to be installed
      E: Unable to correct problems, you have held broken packages.

I've spent a bit of time poking around at this to no avail, until I stumbled upon a solution that is - install aptitude and use it to fix the dependency issue!

Indeed.

root@domains:~# apt install aptitude

then:

root@domains:~# aptitude install lighttpd

and choose downgrade libss1.1

and lighttpd installs and pi-hole works again.


This was a much harder solution to find than it should have been and something is really screwy with these packages. 

Hope this helps!

No comments:

Post a comment